PreviousClose() returning NA

Discussion in 'Troubleshooting' started by James Meyer, Feb 15, 2018.

PreviousClose() returning NA

  1. James Meyer

    James Meyer Member

    Joined:
    May 3, 2017
    Messages:
    67
    Likes Received:
    4
    PreviousClose() function is returning NA this morning (8:30 EST) on Dow, S&P and NASDAQ.
     
  2. marketxls

    marketxls Administrator
    Staff Member

    Joined:
    Dec 21, 2015
    Messages:
    1,119
    Likes Received:
    10
    Hi James,

    This seems to return correct value now for 90.81. In the morning when market opens, there is a slight delay when our feed starts coming in from Qoutemedia. I will check this tomorrow 8.30 EST.


    =PreviousClose("MSFT")

    Thanks
     
  3. James Meyer

    James Meyer Member

    Joined:
    May 3, 2017
    Messages:
    67
    Likes Received:
    4
    IT had been working correctly at about that time on weekdays for some time. Yesterday must have been a gremlin. Worked correctly last night and again this morning at 8:00 EST. Thanks for the reply.
     
  4. James Meyer

    James Meyer Member

    Joined:
    May 3, 2017
    Messages:
    67
    Likes Received:
    4
    Again returning NA at 8:03 AM EST on all three markets, Dow, S&P and NASDAQ.
     
  5. joe__cunningham

    joe__cunningham New Member

    Joined:
    Feb 9, 2017
    Messages:
    5
    Likes Received:
    0
    Hello - I'm having the exact same issues here. Most of my stocks are .AX (Australia). Very unstable experiences in the past few days.
     
  6. marketxls

    marketxls Administrator
    Staff Member

    Joined:
    Dec 21, 2015
    Messages:
    1,119
    Likes Received:
    10

    Ok, we are checking this out.

    Thanks
    Ankur for MarketXLS
     
  7. James Meyer

    James Meyer Member

    Joined:
    May 3, 2017
    Messages:
    67
    Likes Received:
    4
    Ankur, I have sent you a message containing my test file, just to be sure my syntax is correct.
     
  8. joe__cunningham

    joe__cunningham New Member

    Joined:
    Feb 9, 2017
    Messages:
    5
    Likes Received:
    0
    Hello
    This evening (9pm Singapore time) =PreviousClose() is working for my NYSE stocks, but not Australian stocks (e.g. "CBA.AX") nor managed funds like Fidelity (e.g. "FBAKX") - these are all returning NA.
    Thanks
     
  9. marketxls

    marketxls Administrator
    Staff Member

    Joined:
    Dec 21, 2015
    Messages:
    1,119
    Likes Received:
    10
    We are checking this Joe. I will come back to you. The best option for ASX and Other assets is with Barchart addon.
    Barchart

    But we are checking this out and will come back shortly.

    Kind regards
    Ankur
     
  10. James Meyer

    James Meyer Member

    Joined:
    May 3, 2017
    Messages:
    67
    Likes Received:
    4
    Worked once yesterday, but now, 8:00AM EST, is not working. You referenced "80.91" in your first note, not sure what that is.
     
  11. marketxls

    marketxls Administrator
    Staff Member

    Joined:
    Dec 21, 2015
    Messages:
    1,119
    Likes Received:
    10
    Hi James,

    Just tried this now. =PreviousClose("MSFT") it gives me 92.72

    This was indeed the close price as 4PM yesterday. Can you check again? Are you not getting this value?

    Thanks
     
  12. marketxls

    marketxls Administrator
    Staff Member

    Joined:
    Dec 21, 2015
    Messages:
    1,119
    Likes Received:
    10
    I tried this at 8.20 EST.
     
  13. marketxls

    marketxls Administrator
    Staff Member

    Joined:
    Dec 21, 2015
    Messages:
    1,119
    Likes Received:
    10
    Ok, I think I know what you mean. Its the Indices. I see the issue.

    Thanks for notifying. Let us work on this.

    Thank You
    Ankur
     
  14. Greg Lubushkin

    Greg Lubushkin New Member

    Joined:
    Apr 24, 2017
    Messages:
    10
    Likes Received:
    2
    I'm getting NA on most of my US preferreds and certain mutual funds using the previous close function. This has been an ongoing minor issue but this morning it's problematic.
     
  15. joe__cunningham

    joe__cunningham New Member

    Joined:
    Feb 9, 2017
    Messages:
    5
    Likes Received:
    0
    Ankur
    Thanks for the response. It's now been about a week since I've been able to use the service. With the exception of my few NYSE stock, I'm getting NA for everything. I have not checked out the Barchart service - and not sure why I would need to, given my use of your service is relatively simple and these functions have worked perfect for the past few years. Please advise if you see an end to this issue in sight. Thanks.
     
  16. brennanr2

    brennanr2 New Member

    Joined:
    Nov 4, 2017
    Messages:
    10
    Likes Received:
    1
    Same issue, a bunch of mutual funds are not working.
     

Share This Page