Several functions returning NA when using "Refresh All"

Discussion in 'Troubleshooting' started by James Meyer, Feb 24, 2018.

Several functions returning NA when using "Refresh All"

  1. James Meyer

    James Meyer Member

    Joined:
    May 3, 2017
    Messages:
    67
    Likes Received:
    4
    Through last evening and again this morning (7:55 EST, 2/24/2018) "Refresh All" returned "NA" for =LastTrade_PriceOnly and =Change for most of my preferred stocks and mutual funds. NA was also returned on indices numbers for S&P and NASDAQ. When I individually selected the preferred stocks, mutual funds and indices, correct data was returned on all items except =LastTrade_PriceOnly for two mutual funds, FAGIX and FGMNX.
    I changed =LastTrade_PriceOnly to =Last and ran "Refresh Selected" and received correct data on those two mutual funds. Not sure what the difference in update routine for "Refresh All" versus "Refresh Selected" is, but clearly something.

    Also not sure why =LasteTrade_PriceOnly returned "NA" against the two Fidelity MF, but =Last returned correct data.
     
  2. Ted Hatch

    Ted Hatch New Member

    Joined:
    Jul 3, 2017
    Messages:
    18
    Likes Received:
    2
    I am also getting NA for LastPriceRealTime() of 4 mutual funds: VFICX, VWEHX, FBNDX, and FDMMX. I refresh this spreadsheet every 2 weeks on Saturdays, and quite frequently there is a similar problem. Usually after I complain it gets fixed in a day or two. But why is there a problem so often with getting mutual fund prices?
     

Share This Page